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BDLC installation in a MinRole Server
Due the new SharePoint MinRole architecture, the BDLC is not able to be deployed correctly leading to experience some issues with the BDLC background update.
Error
When the BDLC is installed in the WFE and App servers, after enabling the Background Update it's noted that the scheduled sync is never triggered. Although the BDLC job appears in the Scheduled jobs in the Web Front-End server.
Cause
SharePoint full-trust solutions like the BDLC are targeted either to WFE or to application servers. WFE solutions cannot be deployed on pure application servers, it need a web component installed on the server to be recognized as a target for WFE solutions. In a MinRole environment, the application server is therefore ignored by the deployment job when the BDLC (as a WFE solution) is deployed.
Workaround
If the application server has at least one web service component activated temporarily, the deployment job will recognize this as a deployment target for the BDLC.
Solution:
Activate the Central Administration in the backend Application Server where the BDLC is installed:
Go to > IIS Manager -> Application Pools -> SharePoint Central Administration v4 -> Select & Right Click Start or Select & from the Actions Panel Right Click Start
If the BDLC was already installed in the APP server before doing this workaround, you must wait till the deployment job deploys the BDLC correctly, this would take a maximum of 15 min. and there will be no notification of the process (this is a SharePoint background task and you will not be able to see the process).
After is confirmed that the BDLC background update is working properly, it's optionally to deactivate the Central Administration (in some cases the CA MUST stay activated, in such cases isn't a problem that the CA remains activated).
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